SPIA Release History

Date

Version

History

25-08-2020 3.4.1.0

New features
 License server security update.
Corrected bugs
 External startmodel: STDs from file were not applied.
 Advanced inversion: Applying STD to resistivity and depth
did not work properly.

30-04-2020 3.4.0.0

New features
 New updated ProTEM importer. Support for all transmitter
configurations.
 WalkTEMImporter: Support for offset in Z direction for
receiver loop.
Corrected bugs
 When using external start model from file, STDs were not
read correctly.
 Changing InUse flags on raw data by ‘Disable
positives’/’Disable negatives’ buttons did not trigger a
reprocessing of data.
 If a station had been renamed, models imported from SPIA
to Workbench would not have the correct station label.
 Showing stations on map did in some cases not work.
 USFImporter: Improved log/error messages.
 WalkTEMImporter: If coordinates were missing from first
station, entire project would not get an EPSG.

06-02-2020 3.3.2.0

Corrected bugs
 If Offset Loop configuration, do not auto-disable negative
data points.
 Show Graph functionality under Model tab was broken.
 Run All: Do not show individual info messages from each
station.
 Run All did not work after deleting a station.
 Show stations on map would also show deleted stations.
 Amira/ESF importer: Check that Ramp Off time is not zero.
 WalkTEMImporter: Continue import if a broken station is
found.

17-12-2019 3.3.1.0

Corrected bugs
 Bugfix for deleting newly created inversion nodes.
 Improved saving of axis settings for models.
 Open Street Maps support added.

06-12-2019 3.3.0.0

New features
 Support for IP inversion on TEM data (Cole-Cole and
MPA).
 Support for import of integral IP for DC data.
 Support for IP inversion on DC IP data.
 New functionality for enabling/disabling either only
positives or only negatives in the selected data.
 Possibility to disable forward calculations in Edit mode.
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Possibility to use existing model in project as start model.
Export: Station name added as column in xyz file.
Export to images/csv enabled when multiselecting.
Export: Show station name for models.
Show on map: Label positions with station name.
WalkTEM: Support for import and inversion of X and Y
components.
Corrected bugs
 Do not reset zoom on multiselect.
 Several minor bugfixes for loading external start model.
 Bugfix for merging channels on drag-drop.
 Bugfix for drag-dropping two channels to the the same
station.
 Offset loop configuration: Do not disable negative data,
always run in linear space, and never use approximate
derivates.
 Export immediately after coordinate transformation would
export in old EPSG.
 Database path was limited to 128 characters.
 WalkTEM Importer: Skip sps lines where coordinates are
zero.
 Amira/ESF and USF Importer: Bugfix when importing data
where station names already exist in project.
 Amira/ESF Importer: The usf file created had field shift
factor = Nan instead of 1.
 Amira/ESF Importer: Add gate time shift before checking if
gate is located inside ramp and setting quality of the point to
off.
 Amira/ESF Importer: Data was not imported when only one
file was selected in the list.
17-10-2018 3.2.1.0

New features
 Sounding position are shown by Open Street Maps.
 When drag-dropping a channel to a different sounding, do
not merge channels if they have different receiver offsets.

07-02-2018 3.2.0.0

New features
 WalkTEMImporter/HGGWalktemImporter: Support for
different gate time shifts and gate factors on hardware
channels.
 ESF import: Possibility to convert coordinates to different
EPSG.
 ESF import: Support units as column.
 ESF import: Support for ‘Line’ as sounding separator.
 ESF import: Prompt user for TxArea and RxArea if they do
not exist in data file.
 ESF import: Support for several ‘&’ separated header lines.
Corrected bugs
 Inversions labelled ‘final’ could not be exported to csv file
and image.
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03-01-2018 3.1.0.0

New features
 Entering a coordinate in lat-long format will now only
change EPSG if no EPSG has been set for the project.
 EPSG selector is moved to the project node.
 Changing the EPSG will trigger a recalculation of UTM
coordinates for the entire project.
 USF importer: It is assumed that ChannelNo =1 if
‘/Channel’ doesn't exist.
Corrected bugs
 TEM: If project has two or more datasets could give an
range check error when selecting stations.
 DC import: Do not allow import of lines with same
combination of MN and AB/2 (gives error in Wenner
correction).

03-11-2017 3.0.2.0

New features
 If project contains EPSG, also show it for stations where
UTM coordinates are not set.
Corrected bugs
 Improved handling of temporary files to avoid occasional
I/O errors and ‘.emo/.fwr files not found’ errors.
 DC: UTM coordinates were not loaded for Schlumberger
projects.
 Do not allow setting UTM coordinates without choosing an
EPSG.
 USF importer: Bugfix for import of data without
coordinates.

27-10-2017 3.0.1.0

Corrected bugs
 EPSG bugfix for databases without coordinates.
 Backwards compatibility for older databases without Field
Polarity information.

25-10-2017 3.0.0.0

New features
 Support for all EPSG coordinate reference systems (in
meters)
 Update of ribbon user interface including hints.
 Significant speed-up in load of projects.
 It is now possible to invert using L1 norm (‘Blocky’ mode)
instead of L2 norm.
 Possibility to use external start model.
 DC: Support for import of different configurations
(Schlumberger, Wenner, dipole-dipole, and general). Only
one type of configuration per project is allowed.
 TEM: Copy sounding feature (all channels, without models).
 TEM: Possibility to move GPS position (defined by a
distance in meters and a direction).
 Last used inversion settings will be saved and used for
creating start model for next inversion.
 Possibility to export model as image or CSV file.
 Rebuild of database feature.
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ESF TEM: It is now possible to import and invert X and Y
components.
Corrected bugs
 ABEM WalkTEM importer: Fixed a bug in sorting of
stations.
 DC: Models did not have UTM coordinates and could not be
seen in Workbench.
 TEM: Do not run spike filter if segment has less than 10
sweeps.
 In some cases, changing the STD of data points would not be
written correctly in the database.
 Collapsed/expanded status of nodes in the tree would not be
remembered.
 Fixed a bug in automatic renaming of nodes when using
Signal/Noise functionality.
 Protem Importer: Sweeps with zero current are now always
labelled as noise.
 Protem Importer: First sweep in segment would always be
labelled as noise.
24-05-2017 2.3.1.0

New features
 Executables are digitally signed and timestamped to aid
users and virus-scanners verify their authenticity.
Corrected bugs
 Exported dat and syn files did in some cases not contain the
correct data.

22-05-2017 2.3.0.0

New features
 HGGWalkTEMImporter: Possibility to split data from
different hardware channels in different soundings.
 HGGWalkTEMImporter: CoilAmpGains are no longer read
from the ini file, but directly from the data file.
 ProtemImporter: Support more channels in Protem47 mode.
 Possibility to not automatically disable negative data during
inversion (DisableNegativeDuringInversion=No in
[em1dinv] section in SPIAConfig.ini).
Corrected bugs
 HGGWalkTEMImporter: Allow negative offsets on Rx.
 Bugfix for normalization of data where hardware channels 0
and 1 uses different Gains.

14-03-2017 2.2.0.0

New features
 Improved start resistivity for DOI calculations when running
simple inversions
Corrected bugs
 A bug in the spike filtering of raw data would cause to much
raw data to be disabled.
 Corrected some labels in export files.
 ESF Importer: Imported data containing dummy values
could not be inverted.
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09-11-2016 2.1.3.0

Corrected bugs
 Stations containing inversions could not be deleted.
 Changing smoothness in dropdown for Standard Inversion
did not have any effect on the inversion result (smoothness
was always ‘Normal’).
 Warning that TxArea is not found in database when showing
inversions would be shown multiple times.
 Bugfix in load of frontgate
 HGGWalkTEMImporter: Optimize filter settings on import.

26-10-2016 2.1.2.0

Corrected bugs
 Charts were drawn incorrectly in model reports.
 Corrected wrong channel info in model reports.
 Models with depths > 1000 m were plotted incorrectly.
 If inversions were performed before setting an EPSG for the
project, models could not be imported into Aarhus
Workbench.
 STDs were plotted as to large on data in RhoA (graphical
error only).
 ESF importer: Keywords are now case insensitive.

18-10-2016 2.1.1.0

Corrected bugs
 Removed warning that preferences cannot be saved for nonadmin users.

17-10-2016 2.1.0.0

New features
 Allow mixed Offset Loop/Central Loop configurations and
inversion.
 Sign on data can be seen by checking ‘Show Sign’ on Data
View tab.
 Stacked data points for gates where all raw data is off are no
longer visible/selectable on plot.
 Raw data in use flags are no longer affected by changing
stacked data in use flags.
 New select tool: Select all points for all series within a box.
 Display position of mouse on data charts.
 Support for plotting multiple channels or models.
 Front gate time is shown with channel info.
 Receiver position is shown and may be altered in channel
info.
 Include channels for inversion functionality moved from
Preferences to Inversion tab.
 Model info moved to new Model tab which becomes visible
when a model is selected.
 Support for up to 12 channels.
 Support for connection to license server through proxy
server.
 Possibility to flip data sign for a channel using ‘Flip Sign’ on
Data View tab.
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Possibility to convert a noise channel to a data channel and
vice versa using ‘Signal/Noise’ on Data View tab.
 Possibility to enter coordinates in UTM format.
 Possibility to open importers from SPIA and import raw data
into an existing project.
 F1 online help.
 New Importer: ESF/Amira format can now be imported.
Corrected bugs
 Improved rendering quality of charts in pdf reports.
 Model colors now match channel colors.
 When changing between soundings, selected channels is no
longer reset.
 First gate time would sometimes be wrong in channel info.
 Do not reset zoom level when points are toggled on/off.
 USFImporter: Save log file to disk. More useful error
messages.
08-01-2016 2.0.2.0

Corrected bugs
 Fixed an importer bug.

14-12-2015 2.0.1.0

Corrected bugs
 Fixed a bug in the automatic update of Firebird.

10-12-2015 2.0.0.0

Note: Firebird 2.5 is required from this version.
New features
 A channel can be drag-dropped into a different station. If
channel number does not already exist, the channel is
moved. If it exists, the raw data from the two channels is
stacked in case the two channels have the same gate times,
current, and repetition frequency. Otherwise the channel is
assigned a new number and moved. Undo-button for dragdrop is located in the Tree-tab.
 ‘Select Series’ tool added as a Chart Functionality under the
Data View tab. Used for enabled/disabling points in an entire
sweep.
 Axes on model plots for all station models may be set in
Preferences.
 Online help (F1) enabled.
 New Project functionality enabled.
Corrected bugs
 Splitter between sub-windows enabled.
 Improved design of Preferences.
 Do not change axes for model plots when entering/leaving
edit mode.
 In some cases it was possible to start several inversions at
the same time, which caused an error.
 Not all channels were imported when using the import
functionality.

12-05-2015 1.2.3.0

Corrected bugs
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Fixed a bug in the importers that could cause data without
frontgates to fail to import

06-05-2015 1.2.2.0

New features
 The Borland Database Engine (BDE) has been replaced by
the InterBase Data Access Components (IBDAC) in all
instances. It should no longer be necessary to have the BDE
Information Utility installed in order to run SPIA-TEM.
 On inversion, SPIA-TEM would sometimes report an
em1dinv error with a missing error file. The inversion folder
is now copied to the work directory and a message is shown
asking the user to attach the files to the error report
Corrected bugs
 Resistivity/Depth textbox no longer accepts illegal
characters

23-04-2015 1.2.1.0

Corrected bugs
 Added files that were missing in the update package

22-04-2015 1.2.0.0

New features
 Improved SPIA-TEM performance significantly for
workspaces with a high node count.
 USF-Importer will now perform Frontgate-filtering before
importing from USF-file to GERDA.
 Importers now store their own name and version with SPIATEM data.
 Importer name and version are now displayed in the info
sheet if available in the given dataset
 Changed the way stations are named in
HGGWalkTEMImporter so that they are easier to correlate
with field notes
 The error message box that appears when running an
inversion with too few enabled points has been changed
 Default DOI value changed from 500m to 800m in the
SPIAConfig.ini
Corrected bugs
 The Import functionality under the File tab should now
operate correctly. Refer to the manual for information on
how it works.
 Fixed a bug where models would not update their
coordinates when the station coordinates were changed
 Recording Time should now be displayed correctly in the
info tab when a sounding is selected
 'Data points in use' should now update correctly on the info
sheet when setting points in use / not in use
 Fixed a bug that would sometimes cause the wrong node to
be shown with the Show Location button

25-02-2015 1.1.5.0

New features
 Manual can now be opened from the starting window
 Release History can now be opened from the starting
window
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Corrected bugs
 WalkTEMImporter: Fixed a problem that occurred if the
user was pointing to an import folder with empty subfolders
 SPIA-TEM: Fixed compatibility with database files created
using an old importer
.
16-01-2015 1.1.4.0

Corrected bugs
 WalkTEMImporter: Fixed an issue preventing longer
measurement times than 65535 µsek.
 WalkTEMImporter: A log file is now written if an error in
converting the files occur. The version no. can be find in this
log file.

28-11-2014 1.1.3.0

New features
 The minimum number of points per channel required for an
inversion can now be set in SpiaConfig using
MinPointsPrChannel.
Corrected bugs
 Fixed an issue that caused SPIA to incorrectly return a
‘Please Report..’ error when trying to run an inversion with
no TEM files. This now yields a simple error message.

04-11-2014 1.1.2.0

New features
 Front gate time may be included in inversion.
Corrected bugs
 WalkTEMImporter: Current was not imported correctly for
sps files with very few lines.

13-10-2014 1.1.1.0

New features
 STDs cannot be changed in Raw data view. These have
never been used, since the stacked STDs are generated from
the averaging of the sweeps.
 License may now be unregistered without opening a
database.
Corrected bugs
 Instrument mode: Tree was partly visible.

27-08-2014 1.1.0.0

New features
 Negative data are always removed when inverting data. If
negative data is removed, it can be seen in the project log
(File -> Show Project Log).
 Lines in data plot may be turned on/off using a checkbox
under Data View -> Data Transforms.
 Possibility to correct for CoilAmpGains entered wrong when
measuring.
 First gate time shown in metadata is now the first gate that
may be used for inversion, instead of the actual first gate in
measurement.
 Logo may be added to Model Reports by giving a path to the
logo in the inifile or under File -> Preferences..
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Model Report settings may be changed under File ->
Preferences.
 Database engine changed from BDE to IBDAC.
Corrected bugs
 When changing coordinates, new GPS position was not
saved correctly in model tables in database after inversion.
 Instrument mode: Show layered model instead of smooth
model.
 Instrument mode: Residual, DOI and number of layers was
disappearing when switching beetwen data og model views.
 Instrument mode: Buttons on WalkTEM did not work
properly in SPIA-TEM.
 WalktemImporter: Southern hemisphere GPS coordinates
now imported correctly.
 WalkTEMImporter: When the number of shots was the same
for high and low moment, the correct current could not be
identified from the sps file(s).
29-04-2014 1.0.1.19

New features
 Installer: Do not install Borland Database Engine and
Firebird if these are already installed.
 Possibility to add TXRampLM and TXRampHM in inifile
and use these for waveform generation instead of generating
from RampTimeOn, RampTimeOff and repetition
frequency.
 Disabled data points with no value are printed as 999 instead
of NaN in .tem files.
 Show lines between data points on charts.
Corrected bugs
 Bugfix in Walktem Importer to make the WUI-ImporterSPIA-TEM workflow function properly on the instrument.
 Data point total and in use are not shown on station level.
 Bugfix for transmitter loop areas different from 1600.
 Bugfix for model report functionality: Some soundings were
duplicated in the pdf report.
 Bugfix for model report functionality with very large
datasets.

02-04-2014 1.0.1.18

Corrected bugs
 Graceful error message when trying to invert negative data.
 Fixed bug when opening recent projects with long names
containing ‘(…)’ in the display.

01-04-2014 1.0.1.17

Corrected bugs
 Improved general performance and smoothed out a few
hiccups

31-03-2014 1.0.1.16

Corrected bugs
 Fixed behaviour ‘View Manual’ and ‘View Release History’
buttons

31-03-2014 1.0.1.15

Corrected bugs
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PDF model reports should now work correctly for all OS and
screen resolutions

07-03-2014 1.0.1.14

New features
 Possibility to create PDF model reports for a single station,
or for all stations in the project with the same edition label.
Known issue: model report does not work properly for
selected OS/screen resolutions. Work in progress!
 Possibility to disable selected channels during inversion for
all stations in a project.
Corrected bugs
 Saving corrected GPS coordinates working again.
 Optimization of tree update after inversion and
enabling/disabling points.
 Edit mode for advanced inversion stabilized.

19-12-2013 1.0.1.13

Corrected bugs
 Fixed an issue causing ‘Floating point division by zero’
during auto-processing of data with very small stack sizes.
 Fixed some issues causing errors for databases with no GPS
information.
 Fixed issue causing only channels with channel number < 4
to be inverted.

09-12-2013 1.0.1.12

Corrected bugs
 Fixed bug caused by nonadmin users not having write access
to C:\Program Files.

20-11-2013 1.0.1.11

New features
 Colors on data and model plots can now be set via RGB
values in SPIAConfig.ini
 Stack size is now shown as metadata
Corrected bugs
 Much better handling and display of errors from inversion
code
 Tree navigation optimized – much faster now
 Proper formatting of values in model output grid
 Check for updates has been moved to program startup, and
there is now a progress bar showing download progress
 STD on noise channels is set to the uniform STD

02-10-2013 1.0.1.10

Corrected bugs
 Fixed error in modfile which caused all inversion to crash
 Fixed plot error showing up for selected negative
GateTimeShifts

30-09-2013 1.0.1.9

Corrected bugs
 Edition label bug fixed.

20.09.2013

Corrected bugs
 SPIA-TEM now works properly without internet connection.
 WalkTEMImporter does now not crash on negative
GateTimeShift in the inifile.

1.0.1.8
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